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Redefine Style Sheet 2.0

Set Up

Minimum requirements

Mac 0S (8.6 or 9) and QuarkXPress (4.1x or 5.0x).
or
Mac 0S X and QuarkXPress 6.x.

Installation

Download the latest version of Xpedient software from the Xpedient web site,
www.xpedient.com. Drag the file “Redefine Style Sheet” to your “XTension”
folder (in the Quark XPress folder). Relaunch QuarkXPress.

Demonstration mode limitations

Until you put in your license key, Redefine Style Sheet loads in
demonstration mode, where you can use it 25 times. The Redefine Style
Sheet XTension does not put QuarkXPress itself into demo mode. All the
features are enabled, but the Redefine confirmation dialog box cannot be
disabled. Entering a valid license key removes these limitations.

Ordering your license key

A key for Redefine Style Sheet 2.x works on both the QuarkXPress 4 & 5
version, and the QuarkXPress 6 version. To buy your license key go to our
web site at www.xpedient.com, email us at sales@xpedient.com, or call
781-647-1050. Please make checks payable to Xpedient Corporation, and
mail to the address on the first page of this manual.

Unlocking to remove demo limitations

To enter your license key in Mac 0S 8 or 9, go to Edit > Preferences >
Redefine Style Sheet and click the Unlock button. In Mac 0S X choose
QuarkXPress > Preferences, and click on Redefine Style Sheet in the list.

Click Unlock, and put your name, company and license key in the space
provided. Since the key is long, we suggest that you copy it from our email,
and paste it into the Key field. The license key provides unlimited use, and
allows you to turn off the confirmation dialog.

Please report any problems or comments to
support@xpedient.com or call 781-647-1050.
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About Style Sheets

What is a style sheet?

Style sheets are sets of style formats that you create and use to control text
formatting. Paragraph style sheets control paragraph settings such as
alignment, indents, leading, hyphenation, etc. Character style sheets cover
only the format of the character itself, such as font, color, size, shade. In
QuarkXPress, the paragraph style sheets have character settings too, each has
its own “Default” character style that’s made automatically when you make a
paragraph style sheet. When creating style sheets, keep things simple: unless
you need to apply character settings without affecting paragraph settings,
just make and use paragraph style sheets.

Why use style sheets?

Style sheets save time, prevent tedious error-prone work, and make it easier
to create a consistently typeset product. Instead of using the Style menu
again and again, use a style sheet to apply all your formats in one click.
Redefine a style sheet to see any design changes in place throughout your
document immediately.

Why doesn’t everyone use style sheets?

Making new style sheets in QuarkXPress is not too hard, but adjusting them
is painful. The four very dense Edit > Style Sheet dialog boxes don't have an
Apply button, so you're unable to easily experiment with formatting there,
so you must try ideas on the page, write down the numbers from the
Measurements palette and dialog boxes, and then update the style sheet by
entering the information in the correct fields.

The Redefine Style Sheet Xtension

The Redefine Style Sheet XTension makes it fast and easy to define, apply,
rename, and redefine style sheets. This industrial-strength software keeps
track of hundreds of design specs so that designers can experiment freely,
and production artists can save a lot of time.
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Using Redefine Style Sheet

To redefine a style sheet without the Redefine Style Sheet Palette.

1. Select text that has a style sheet plus local formatting.

2. Type your shortcut keystroke as defined in the Redefine Style Sheet
Preferences. The optional confirmation dialog box informs you which of
the settings will change for the character and/or paragraph style sheet(s).
Click OK to redefine the style sheet, or click cancel if you just wanted to
see how the selected text differs from the current style sheet definition.

You can use the confirmation dialog box just to see which specs are locally

applied, just press cancel after you have seen the information you need.

Introducing the Redefine Style Sheet palette

To show the new Xpedient Redefine Style Sheet 2 palette, in QuarkXPress 4

and 5, choose View > Show Redefine Style Sheet. In QuarkXPress 6, choose
Window > Show Redefine Style Sheet. The palette itself is the same in both
versions.

This button changes according to the current

Field Labels - click to open selection. Use the option key to toggle between
Edit Style Sheet dialog box Apply and Redefine, or Define and Rename.
|
@i Redefine Style Sheet "1 i T
* Paragraph style sheet
" / /EI Redefine
Charagtér style sheet |
|4 y
.These. fields are dls.amb{guatmg fields, Popup menus, (paragraph style sheets on
just like the Font field in the top, character style sheets below).

Measurements palette, so you can
type the first few letters to quickly
show an existing style sheet.

Select text on any page, and the palette shows the style sheet(s) used by the
selection. The top field shows the paragraph style sheet, and the bottom field
shows the character style sheet. The plus sign (+) to the left of any style
sheet name appears only when local formats are used in the selection.

To define a new style sheet

1. Select formatted text on your page, and type a new name in the
appropriate field in the palette. The button now says Define.

2. Click the button to define the new style sheet. This also applies the newly
defined style sheet to the selection. That's the Xpedient way.
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To redefine an existing style sheet using text with that style sheet

1. Select locally formatted text on your page, the palette shows the style
sheet name(s), and the button says Redefine.

2. To redefine both paragraph and character style sheets, click the Redefine
button.

3. To redefine just the character style sheet, first click in the character style
sheet field, then click Redefine.

4. To redefine just the paragraph style sheet, first click in the paragraph
style sheet field, then click Redefine.

To redefine an existing style sheet using any formatted text, even if
it has a different style sheet applied

1. Select formatted text to use as the source for the style sheet.

2. Choose a style sheet from the popup menu. You can also select a style
sheet by clicking in one of the fields and typing the first few letters until
the name is filled in for you (this works the same way as the Fonts field in
the Measurements palette). The button changes to Apply.

3. Hold the option key to change the button to Redefine. Click the button to
redefine the style sheet. This also applies the newly redefined style sheet
to the selection.

To apply an existing style sheet to text

1. Select text, and ignore the contents of the fields in our palette.

2. Choose a style sheet from the popup menu in the palette. You can also
select a style sheet by clicking in one of the fields and typing the first few
letters until the name is filled in for you (this works the same way as the
Fonts field in the Measurements palette).

3. Now the button changes to Apply. Click to apply the style sheet to the
selection.

To rename an existing style sheet

1. Click in text that uses the style sheet you want to rename. The palette
shows the current names.

2. Click in the paragraph or character style sheet name field and change the
name as you like. The button changes to Define. Hold the option key, it
changes to Rename. Click the button to rename.
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Preferences

To set your preferences in Mac 0S 8 or 9, go to Edit > Preferences > Redefine
Style Sheet. In Mac 0S X choose QuarkXPress > Preferences, and click on
Redefine Style Sheet in the list.

Confirmation dialog box

You can choose whether to have the confirmation dialog display each time
you redefine a style sheet by clicking the checkbox.

Protecting certain style sheets

You can prevent the Redefine Style Sheet Xtension from affecting certain
style sheets. (Although you may still redefine those style sheets using the
Edit Style Sheet dialog boxes.) To protect the «Normal» style sheet, check its
checkbox in the Protected Style Sheets section of the Preferences dialog. To
protect other style sheets, simply enter your own prefix and/or suffix
character(s) in the Preferences dialog, and add the same prefix or suffix
character(s) to the names of the style sheets you want to protect. Redefine
Style Sheet will refuse to redefine or rename those style sheets.

Keyboard shortcuts

You may define any available keystroke as a trigger to the Redefine Style
Sheet function, which will work depending on the selection.

The Define, Apply, Rename, and Redefine From Any Selected Text
functions are only available through the palette since they require you to
type or choose a style sheet name.

Frequently Asked Questions and Support

How does Redefine Style Sheet work?

Quickly. Users can avoid the overly complex dialog boxes that control style
sheets, and simply use samples on pages. Now style sheets are so fast to
update that designers use them to show multiple variations instantly. Style
sheets are not just for production wizards anymore.

Can’t you just redefine style sheets without an XTension?

Yes, but it's not quick or easy. Choose Edit > Style Sheets to make your
changes in the dialog boxes, but you can’t see what you're doing. Or you can
make your changes on a sample of text, and use the Replacement Routine, a
procedure that users have invented to solve the problem. See our web page
for details.
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Is there a Windows version?
No. Do you need one?

Support
Write to support@xpedient.com or call 781-647-1050.

Revision History

1.0.2: Added French language support.
1.1: Added the ability to protect certain style sheets.
2.0: Added palette and several features including Define, Rename, and Apply.

Known Issues

If you use based-on style sheets, and redefine the parent, the child style
sheets do not update. When you are redefining the parent style sheets, use
the Edit > Style Sheets menu command instead of Redefine Style Sheet.

Please report any problems or comments to
support@xpedient.com or call 781-647-1050.

Lawyer Talk
Copyright ©1999-2004 by Xpedient Corporation. All Rights Reserved.

Portions copyrighted 1988-1998 Quark Technology Partnership.
All Rights Reserved.

Redefine Style Sheet is for use with Mac 0S QuarkXPress 4.11, 5.%, or 6.x.

LICENSE: This end user license grants permission per user. We encourage you
to make backup copies, but the number of simultaneous users, whether
networked together or not, must not exceed the number of licensed users.

LIABILITY: The information in this book and the computer software are
distributed on an “As Is” basis, without warranties or guarantees of any kind.
While every precaution has been taken in their preparation, Xpedient shall
have no liability to any person or corporation with respect to any loss or
damage caused or alleged to be caused directly or indirectly by the instruc-
tions contained in this book or by the computer software described in it.

Quark, QuarkXPress, QuarkXTensions and XTensions are trademarks of Quark,
Inc. and all applicable affiliated companies, Reg. U.S. Pat & Tm Off. and in
many other countries. The Quark logo and the XTensions logo are trademarks
of Quark, Inc. and all applicable affiliated companies. Mac 0S is a trademark
of Apple Computer, Inc. All other trademarks are the properties of their
respective owners.
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The following disclaimer is required by Quark, Inc.

Quark, QuarkXTensions and XTensions are trademarks of Quark, Inc. and all
applicable affiliated companies, Reg. U.S. Pat. & Tm. Off. and in many other
countries. The Quark logo, the XTensions logo and the Art of
Communication are trademarks of Quark, Inc. and all applicable affiliated
companies.

THIS SOFTWARE PACKAGE HAS NOT BEEN WRITTEN, REVIEWED OR TESTED BY
QUARK, THE QUARK AFFILIATED COMPANIES OR THEIR LICENSORS.
QUARK, THE QUARK AFFILIATED COMPANIES AND THEIR LICENSORS MAKE
NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED
SOFTWARE PACKAGE, ITS MERCHANTABILITY, OR ITS FITNESS FOR ANY
PARTICULAR PURPOSE. QUARK, THE QUARK AFFILIATED COMPANIES AND
THEIR LICENSORS DISCLAIM ALL WARRANTIES RELATING TO THE ENCLOSED
SOFTWARE PACKAGE. ALL OTHER WARRANTIES AND CONDITIONS, WHETHER
EXPRESS, IMPLIED, OR COLLATERAL, AND WHETHER MADE BY THE
DISTRIBUTORS, SYSTEMS INTEGRATORS, RETAILERS OR DEVELOPERS OF THE
ENCLOSED SOFTWARE ARE DISCLAIMED BY QUARK, THE QUARK AFFILIATED
COMPANIES AND THEIR LICENSORS, INCLUDING, WITHOUT LIMITATION,
ANY WARRANTY OF NON-INFRINGEMENT, COMPATIBILITY, OR THAT THE
SOFTWARE IS ERROR-FREE OR THAT ERRORS CAN OR WILL BE CORRECTED.
Some jurisdictions, states or provinces do not allow limitations on implied
warranties, so the above limitation may not apply to particular users.

IN NO EVENT SHALL QUARK, THE QUARK AFFILIATED COMPANIES OR THEIR
LICENSORS BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL,
CONSEQUENTIAL OR PUNITIVE DAMAGES, INCLUDING, BUT NOT LIMITED
TO, ANY LOST PROFITS, LOST TIME, LOST SAVINGS, LOST DATA, LOST FEES, OR
EXPENSES OF ANY KIND ARISING FROM INSTALLATION OR USE OF THE
SOFTWARE OR ACCOMPANYING DOCUMENTATION IN ANY MANNER, HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY. IF, NOTWITHSTANDING THE
FOREGOING, QUARK, THE QUARK AFFILIATED COMPANIES AND/OR THEIR
LICENSORS ARE FOUND TO HAVE LIABILITY RELATING TO THIS SOFTWARE
PACKAGE, SUCH LIABILITY SHALL BE LIMITED TO THE AMOUNT PAID BY USER
TO QUARK WITHIN THE THREE YEAR PERIOD PRECEDING THE CLAIM, IF
ANY, FOR THE LICENSE OF THE SPECIFIC QUARK PRODUCTS (EXCLUDING ANY
THIRD-PARTY COMPONENTS ADDED BY END USER OR ANY THIRD PARTY,
INCLUDING A DEVELOPER OR INTEGRATOR), OR THE LOWEST AMOUNT UNDER
APPLICABLE LAW, WHICHEVER IS LESS. THESE LIMITATIONS WILL APPLY
EVEN IF QUARK, THE QUARK AFFILTATED COMPANIES AND/OR THEIR
LICENSORS HAVE BEEN ADVISED OF SUCH POSSIBLE DAMAGES. Some
jurisdictions, states or provinces do not allow the exclusion or limitation of
incidental or consequential damages, so this limitation or exclusion may
not apply. All other limitations provided under applicable law, including
Statutes of Limitation, shall continue to apply.
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